Протокол V.32bis
Протокол модуляции V.32bis разработан для обеспечения передачи данных со скоростью до 14400 бит/с по двухпроводным
коммутируемым и выделенным телефонным каналам. Данный протокол принят в качестве стандарта ITU-Т в 1991 году.
Основные характеристики модемов, поддерживающих данный протокол, следующие:
> дуплексный режим работы по коммутируемым каналам телефонных сетей общего пользования и арендуемым двухпроводным
линиям передачи;
> реализация эхоподавления;
> применение КАМ для режимов синхронной передачи со скоростью модуляции 2400 Бод;
> частота несущей равна 1800 Гц;
> приемник модема должен обеспечивать бесперебойную работу при не стабильности частоты принимаемого сигнала не более
±7 Гц;
> скорости передачи данных:
- 14400, 1200, 9600, 7200 бит/с с треллис-кодированием;
— 4800 бит/с без кодирования;
> совместимость с модемами V.32 на скоростях 9600 и 4800 бит/с;
> обмен управляющими последовательностями и выбор скорости передачи в течение процедуры установления связи;
> процедура смены скорости передачи в течение сеанса связи без разрыва соединения;
> режим асимметричной передачи не поддерживается; другими словами, скорости передачи и приема каждого
взаимодействующего модема должны быть одинаковы;
> спектр сигнала ограничен полосой частот от 600 Гц до 3000 Гц.
Устройство кодирования по протоколу V.32bis показано на рис. 6.17. При скорости передачи 14400 бит/с на вход кодера
подаются все шесть битов Qln — Q6n в параллельном коде. При скорости 12000 бит/с входная информационная
последовательность разделяется на блоки по пять битов Qln—Q5n. Аналогично, при скоростях 9600, 7200 и 4800 бит/с
задействуются четыре (Qln—Q4n), три (Q1n—Q3n) и два (Qln -Q2n) входа соответственно.
Рис. 6.17.
Схема кодирования информации в модеме V.32bis
Таблица. 6.2. Правило дифференциального кодирования при использовании сигнально-кодовои конструкции
Вход
Предыдущий выход
Выход
Q1n
Q2n
Y1n-1
Y2n-1
Y1n
Y2n
0
0
0
0
0
0
0
0
0
1
0
1
0
0
1
о
1
0
0
0
1
1
1
1
0
1
0
о
0
1
0
1
о
1
0
0
0
1
1
о
1
1
0
1
1
1
1
0
1
0
о
о
1
0
1
0
о
1
1
1
1
0
1
о
0
1
1
0
1
1
0
0
1
1
о
о
1
1
1
1
о
1
1
0
1
1
1
о
0'
0
1
1
1
1
0
1
Два первых бита Qln и Q2n в каждом блоке при любой скорости передачи (индекс п обозначает последов ательный номер блока
информационной последовательности) поступают на дифференциальный кодер, где они перекодируются в биты Y1n и Y2n
согласно табл. 6.2.
Дифференциальные биты Y1n и Y2n используются в качестве входных для систематического сверточного кодера, который
генерирует избыточный бит YOn. Этот избыточный бит и шесть информационных бит Y1n, Y2n, Q3n, Q4n, Q5n, Q6n поступают на
устройство сигнального отображения, которое формирует элементы сигнального созвездия, представленного на рис. 6.18.
Двоичные числа на рис. 6.18 соответствуют последовательности битов YOn, Y1n, Y2n, Q3n, Q4n, Q5n, Q6n, а обозначения А, В,
С, D — синхронизирующим сигнальным элементам.
На скорости передачи 12000 бит/с входной проскремблированный поток данных делится на группы по пять бит. Процесс
дифференциального кодирования и кодирования сверточным кодом принципиально ничем не отличается от кодирования при
скорости 14400 бит/с. При скорости 12000 бит/с формируются элементы сигнального созвездия, приведенного на рис. 6.19.
Двоичные числа на рис. 6.19 соответствуют последовательности шести битов YOn, Y1n, Y2n, Q3n, Q4n, Q5n, а обозначения А,
В, С, D, как и ранее, соответствуют синхронизирующим сигнальным элементам.
Рис. 6.18.
Сигнальная диаграмма для скорости 14400 бит/с
При скорости передачи 9600 бит/с входной проскремблированный поток данных делится уже на блоки по четыре бита Q1n, Q2n,
Q3n, Q4n. В результате этого схема кодера V.32bis при скорости 9600 бит/с соответствуют кодеру V.32. Пространственная
сигнальная диаграмма соответствует диаграмме модемов V.32 при той же скорости передачи (рис. 6.16).
Двоичные числа на диаграмме соответствуют последовательности пяти битов YOn, Yln, Y2n, Q3n, Q4n, поступающих на вход
устройства сигнального отображения.
При скорости передачи 7200 бит/с входной проскремблированный поток данных делится на блоки по три бита Qln, Q2n, Q3n.
Пространственная сигнальная диаграмма для такой скорости передачи приведена на рис. 6.20.
В этом случае двоичные числа соответствуют последовательности четырех • бит YOn, Yln, Y2n, Q3n, поступающих на вход
устройства сигнального отображения.
При скорости 4800 бит/с скемблированный входной поток данных разбивается на блоки по два бита Qln и Q2n, которые и
поступают на вход относительного кодера, работающего согласно табл. 6.3.
С выхода относительного кодера биты Yln и Y2n отображаются в передаваемые сигнальные элементы согласно диаграммы,
изображенной на рис. 6.14. Таким образом, при скорости 4800 бит/с кодирования избыточным сверточ-ным кодом не
происходит.
Рис. 6.19.
Сигнальная диаграмма для скорости 12000 бит/с
Двоичные числа на рис. 6.14 соответствуют последовательности двух бит Yln и Y2n, поступающих на вход устройства
сигнального отображения.
Согласно протокола V.32bis модемы должны иметь два самосинхронизирующихся скремблера. В каждом направлении
передачи используется свой
Рис. 6,20.
Сигнальная диаграмма для скорости 7200 бит/с
Таблица 6.3. Правило дифференциального кодирования при скорости передачи 4800 бит/с
Вход
Предыдущий
Изменение
Выход
Сигнальная точка
выход
фазы
для 4800 бит/с
Q1n
Q2n
Y1n-1
Y2n-1
Y1n
Y2n
0
0
0
0
+90°
. 0
1
В
0
0
0
1
1
1
С
0
0
1
0
0
0
А
0
0
1
1
1
0
D
0
1
0
0
0°
0
0
А
0
1
0
1
0
1
В
0
1
1
о ,
1
0
D
0
1
1
1
1
1
С
1
0
о
о
+180°
1
1
С
1
0
о
1
1
0
D
1
0
1
о
0
1
В
1
0
1
1
0
0
А
1
1
о
о
+270°
1
0
D
1
1
о
1
0
0
А
1
1
1
о
1
1
С
1
1
1
1
0
1
В
скремблер. Вызывающий модем использует скремблер с образующим полиномом
1+х-^х-23,
а отвечающий модем пользуется скремблером с образующим полиномом
1+х-^х-23


Протокол V.33
Протокол V.33 предназначен для обеспечения дуплексной связи по четьт-рехпроводным выделенным каналам на частоте 1800
Гц и со скоростью модуляции 2400 Бод. В режимах протокола СКК-64 и СКК-128 используется квадратурная амплитудная
модуляция совместно с решетчатым кодированием. Благодаря этому достигаются скорости передачи 12000 и 14400 бит/с. Этот
протокол очень напоминает V.32bis без эхоподавления. Схема модема содержит дифференциальный кодер и сверточный кодер
со скоростью 2/3, аналогичный модемам V.32bis.
Манипулирующий входной поток скремблируется самосинхронизирующим скремблером с образующим полиномом
1+х~ +х~ .
Схема скремблера представлена на рис. 6.21.
С учетом дополнительного бита за счет треллис-кодирования скорость передачи выходного потока, модема составляет
2400х7=16800 бит/с.
Рис. 6.21.
Скремблер V.33
Протокол предусматривает подключение мультиплексора на входе модема. Благодаря этому возможна организация нескольких
каналов со скоростями 12000, 9600, 7200, 4800 и 2400 бит/с в одном групповом потоке 14400 бит/с. Возможные варианты
организации таких каналов для разных скоростей передачи приведены в табл. 6.4 и 6.5.
Таблица 6.4. Варианты мультиплексирования при скорости передачи 14400 бит/с
Номер
конфигурации
Скорость в
подканалах,
бит/с
Канал
мультиплексирования
Модуляционные биты
Q1
Q2
Q3
Q4
Q5
Q6
1
14400
А
х
х
х
х
х
х
2
12000 2400
А
В
х
Х
х
х
х
х
3
9600 4800
А
В
х
х
х
х
х
х
4
9600 2400 2400
А В С
х
х
х
х
х
х
5
7200 7200
А
В
х
х
х
х
х
х
6
7200 4800 2400
А В С
х
х
х
х
х
х
7
7200 2400 2400
2400
А В С D
х
х
х
х
х
х
8
4800 4800 4800
А В С
х
х
х
х
х
х
9
4800 4800
А
В
х
х
х
х
9
2400
С
х
2400
D
х
10
4800
A
х
х
2400
В
х
2400
С
х
2400
D
х
2400
Е
х
11
2400
А
х
2400
В
х
2400
С
х
2400
D
х
2400
Е
х
2400
F
х
Таблица 6.5. Варианты мультиплексирования при скорости передачи 12000 бит/с
Номер
конфигурации
Скорость в
подканалах,
бит/с
Канал
мультиплексирования
Модуляционные биты
Q1
Q2
Q3
Q4
Q5
Q6
1
12000
А
х
х
х
х
х
2
9600
А
х
х
х
х
2400
В
х
3
7200
А
х
х
х
4800
В
х
х
4
7200
А
х
х
х
2400
В
х
2400
С
х
5
4800
А
х
" х
4800
В
х
х
2400
С
х
6
4800
А
х
х
2400
В
х
2400
С
х
2400
D
х
7
2400
А
х
2400
В
х
2400
С
х
2400
D
х
2400
Е
х


Протокол V.17
Протокол V.17 является самым скоростным факс-протоколом модуляции. По своим же параметрам он похож на протокол
V.32bis.
Частота несущего колебания принята равной 1800 Гц, а скорость модуляции — 2400 Бод. При этом используются режимы
СКК-16, СКК-32, СКК-64 и СКК-128.
Таблица 6.10. Варианты работы мультиплексора V.29
Номер
конфигурации
Скорость в
подканалах,
бит/с
Канал
мультиплексирования
Модуляционные биты
Q1
Q2
Q3
Q4
1
9600
А
х
х
х
х
2
7200
А
х
х
х
2400
В
х
3
4800
А
х
х
4800
В
х
х
4
4800
А
х
х
2400
В
х
2400
С
х
5
2400
А
х
2400
В
х
2400
С
х
2400
D
х
6
7200
А
х
х
х
7
4800
А
х
х
2400
В
х
8
2400
А
х
2400
В
х
2400
С
х
9
4800
А
х
х
10
2400
А
х
2400
В
х
Соответственно информационная скорость передачи может быть 7200, 9600, 12000 и 14400 бит/с.


Сжатие данных с использованием преобразования Барроуза-Вилера
Майкл Барроуз и Давид Вилер (Burrows-Wheeler) в 1994 году предложили свой алгоритм преобразования (BWT). Этот алгоритм
работает с блоками данных и обеспечивает эффективное сжатие без потери информации. В результате преобразования блок
данных имеет ту же длину, но другой порядок расположения символов. Алгоритм тем эффективнее, чем больший блок данных
преобразуется (например, 256-512 Кбайт). Пояснение работы алгоритма будет выполнено на ограниченном объеме исходных
данных (строка S длиной N, например, SEMENOV). Строка S рассматривается как последовательность, состоящая из N строк.
Сначала осуществляется циклический сдвиг строки S и формируется N-1 новая строка. На практике строки не размножаются, а
создается массив указателей на циклический буфер, где лежит исходная строка S.
Строка
S E M E N O V
S0
E M E N O V S
S1
M E N O V S E
S2
E N O V S E M
S3
N O V S E M E
S4
O V S E M E N
S5
V S E M E N O
S6
Далее выполняется лексикографическое упорядочение (сортировка) этих строк (указателей). Для упорядочения можно
использовать С-функции типа strcmp() или memcmp() (учитывая особенности структуры буфера, это должны быть их
функциональные аналоги).
F
L
Строка
E
M
E
N
O
V
S
S1
E
N
O
V
S
E
M
S3
M
E
N
O
V
S
E
S2
N
O
V
S
E
M
E
S4
O
V
S
E
M
E
N
S5
S
E
M
E
N
O
V
S0
V
S
E
M
E
N
O
S6
Первая колонка помечена буквой F, а последняя Колонка F (EEMNOSV) содержит все символы исходной строки S, записанные
в упорядоченной последовательности. Строка L представляет собой последовательность префиксных символов для строки S.
Результатом работы алгоритма BWT является строка L и первичный индекс, который представляет собой номер элемента строки
L, где хранится первый символ исходной строки S. В приведенном примере индекс равен 1.


Методы Шеннона-фано и Хаффмена
В качестве примера, поясняющего принципы сжатия, рассмотрим простой метод Шеннона-Фано. В чистом виде в современных
СПД он не применяется, однако позволяет проиллюстрировать принципы, заложенные в более сложных и эффективных методах.
Согласно методу Шеннона-Фано для каждого символа формируется битовый код, причем символы с различными частотами
появления имеют коды разной длины. Чем меньше частота появления символов в файле, тем больше размер его битового кода.
Соответственно, чаще появляющийся символ имеет меньший размер кода.
Код строится следующим образом: все символы, встречающиеся в файле выписывают в таблицу в порядке убывания частот их
появления. Затем их разделяют на две группы так, чтобы в каждой из них были примерно равные суммы частот символов.
Первые биты кодов всех символов одной половины устанавливаются в "О", а второй — в "I". После этого каждую группу делят
еще раз пополам и так до тех пор, пока в каждой группе не останется по одному символу. Допустим, файл состоит из некоторой
символьной строки aaaaaaaaaabbbbbbbbccccccdddddeeeefff, тогда каждый символ этой строки можно закодировать как показано
в табл. 8.1.
Таблица 8.1. Пример построения кода Шеннона-Фано
Символ
Частота появления
Код
а
10
11
b
8
10
с
6
011
d
5
010
е
4
001
f
3
000
Итак, если обычно каждый символ кодировался 7—8 битами, то теперь требуется максимум 3 бита.
Однако, показанный способ Шеннона-Фано не всегда приводит к построению однозначного кода. Хотя в верхней подгруппе
средняя вероятность символа больше (и, следовательно, коды должны быть короче), возможны ситуации, при которых
программа сделает длиннее коды некоторых символов из верхних подгрупп, а не коды символов из -нижних подгрупп.
Действительно, разделяя множество символов на подгруппы, можно сделать большей по вероятности как верхнюю, так и
нижнюю подгруппы. В качестве примера такой ситуации служат приведенные ниже две таблицы, где одни и те же символы с
одинаковыми вероятностями появления в файле имеют различную кодировку.
Более удачен в данном отношении метод Хаффмена. Он позволяет однозначно построить код с наименьшей средней длиной,
приходящейся на символ.
Таблица 8.2. Пример кодировки одних и тех же символов различными кодами
Символ
Частота появления
Код
с
22
11
е
20
101
h
16
100
1
16
01
а
10
001
k
10
0001
m
4
00001
b
2
00000
Таблица 8.3. Пример кодировки одних И тех же символов различными кодами
Символ
Частота появления
Код
с
22
11
е
20
101
h
16
011
• ¦
16
010
а
10
001
k
10
0001
m
4
00001
Ь
2
00000
Суть метода Хаффмена сводится к следующему. Символы, встречающиеся в файле, выписываются в столбец в порядке
убывания вероятностей (частоты) их появления. Два последних символа объединяются в один с суммарной вероятностью. Из
полученной новой вероятности и вероятностей новых символов, не использованных в объединении, формируется новый столбец
в порядке убывания вероятностей, а две последние вновь объединяются. Это продолжается до тех пор, пока не останется одна
вероятность, равная сумме вероятностей всех символов, встречающихся в файле.
Таблица 8.4. Кодирование методом Хаффмена
Символ
Частота появления
Вспомогательные столбцы
с
22
22 22 26 32 42 58 100
в
20
20 20 22 26 32 42
h
16
16 16 20 22 26
I
16
16 16 16 20
а
10
10 16 16
k
10
10 16
m
4
6
b
2
Таблица 8.5. Коды символов для кодового дерева на рис. 8.1
Символ
Код
с
01
е
00
h
111
1
110
а
100
k
1011
m
10101
b
10100
Процесс кодирования с использованием метода Хаффмена поясняется табл. 8.4. Для составления кода, соответствующего
данному символу, необходимо проследить путь перехода знака по строкам и столбцам таблицы кода.
Более наглядно принцип действия метода Хаффмена можно представить В виде кодового дерева (рис. 8.1) на основе табл. 8.4.
Из точки, соответствующей сумме всех вероятностей (в данном случае она равна 100), направляются две ветви. Ветви с
большей вероятностью присваивается единица, с меньшей — нуль. Продолжая последовательно разветвлять дерево, доходим
до вероятности каждого символа.
100
Рис. 8.1.
Кодовое дерево для кода Хаффмена
Теперь, двигаясь по кодовому дереву сверху вниз, можем записать для каждого символа соответствующий код (табл. 8.5).


Алгоритм LZW
Непосредственным предшественником алгоритма LZW явился алгоритм LZ78, опубликованный в 1978 г. Этот алгоритм
воспринимался как математическая абстракция до 1984 г., когда Терри Уэлч
(Terry A. Welch)
опубликовал свою работу с
модифицированным алгоритмом, получившим в дальнейшем название LZW
(Lempel-Ziv-Welch).
Алгоритм LZW построен вокруг так называемой таблицы фраз (словаря), которая отображает строки символов сжимаемого
сообщения в коды фиксированной длины, равные 12 бит. Таблица обладает свойством предшествования, то есть для каждой
фразы словаря, состоящей из некоторой фразы
w
и символа
К,
фраза
w
тоже содержится в словаре.
Алгоритм работы кодера LZW следующий:
Проинициализировать словарь односимвольными фразами, соответствующими символам входного алфавита;
Прочитать первый символ сообщения в текущую фразу *г;
Шаг алгоритма:
Прочитать очередной символ сообщения К:
Если КОНЕЦ_СООВЩЕНИЯ
Выдать ход »;
ВЫХОД;
Конец Коли Коли фрааа »К уже есть в словаре,
Заменить х на код фравы wK;
Повторить Шаг алгоритма;
Иначе
Выдать ход w;
Добавить wK в словарь ;
Повторить Шаг алгоритма;
Конец Если;
Пример работы кодера LZW при преобразовании трехсимвольного алфавита приведен в табл. 8.6 и 8.7.
Описанный алгоритм кодера не оптимизирует выбор фразы для добавления в словарь или разбор сообщения. Однако в силу его
простоты он может быть эффективно использован.
Таблица 8.6. Работа кодера LZW на примере трехсимвольного алфавита (а, б, в)
Символ
wK
Выход
Добавление в словарь (фраза — позиция)
а
1
6
6
1
16(4)
а
2а
2
2а(5)
6
16
в
4в
4
4в(6)
б
36
3
36(7)
а
2а
6
56
5
56(8)
а
2а
6
56
а
8а
8
8а(9)
а
1а
1
1а(10)
а
1a
а
10a
10
10a (11)
а
1a
а
10a
'•
а
11a
11
11a (12)
1
Декодер LZW должен использовать тот же словарь, что и кодер, строя его по аналогичным правилам при восстановлении
сжатых данных. Каждый считываемый код разбирается с помощью словаря на предшествующую фразу w и символ
К.
Затем
рекурсия продолжается для предшествующей фразы
w
до тех пор, пока она не окажется кодом одного символа.
Таблица 8.7. Словарь, построенный кодером LZW, для примера из табл. 8.6
Фразы, добавленные в словарь при инициализации
а
1
6
2
в
3
Фразы, добавленные пр
и разборе сообщения
16
4
2а
5
4в
6
36
7
56
8
8а
9
la
10
10a
11
11a
12
При этом завершается декомпрессия этого кода. Обновление словаря происходит для каждого декодируемого кода, кроме
первого. После завершения декодирования кода его последний символ, соединенный с предыдущей фразой, добавляется в
словарь. Новая фраза получает то же значение кода (позицию в словаре), что присвоил ей кодер. В результате такого процесса,
шаг за шагом декодер восстанавливает тот словарь, который построил кодер.
Алгоритм декодирования LZW описывается следующим образом:
КОД 8 Прочитать первый ход сообщения( );
ПредмдущийКОД = КОД;
Выдать символ К, у которого код(К) == КОД;
Последний символ = К;
Следующий ход:
КОД = Прочитать очередной код сообщения( );
ВходнойКОД = КОД ;
Если КОНЕЦ_СООБЩЕНИЯ ВЫХОД;
Конец Если;
Если Неизвестен(КОД) // Обработка исключительной //ситуации
Видать(ПоследнийСимаол) КОД = ПредыдущийКОД
ВходнойКОД = код(ПредыдущийКОД, ПоследнийСимвол) Конец Если;
Следующий символ:
Если КОД == ход(wK) В СТЕК (К);
КОД = код(к) ;
Повторить Следующий символ;
Иначе если КОД == код(К) Выдать К;
По еле днийСимвол в JC;
Пока стек не пуст
Выдать (ИЗ_СТЕКА( )) ;
Конец Пока;
Добавить в словарь (ПредыдущийКОД, К);
Предыдущий КОД а Входной КОД;
Повторить СледующийКОД;
Конец Если;
Обычно декодирование LZW намного быстрее процесса кодирования. Автор LZW Терри Уэлч в свое время сумел запатентовать
свой алгоритм в США. В настоящее время патент принадлежит компании Unisys. Алгоритм LZW определяется как часть
стандарта ITU-T V.42bis, но Unisis установила жесткие условия лицензирования алгоритма для производителей модемов.


Протокол MNP5
Протокол MNP 5 реализует комбинацию адаптивного кодирования с применением кода Хаффмена и группового кодирования.
При этом хорошо поддающиеся сжатию данные уменьшают свой исходный объем примерно на 50% и, следовательно,
реальная скорость их передачи возрастает вдвое по сравнению с номинальной скоростью передачи данных модемом.
На первом этапе процедуры сжатия используется метод группового кодирования для удаления из потока передаваемых данных
слишком длинных последовательностей повторяющихся символов. Этот метод преобразует каждую группу из трех и более
(вплоть до 253) одинаковых смежных символов к виду
символ
и
число символов.
Поскольку групповое кодирование не связано
с большими вычислениями, этот метод особенно хорош для реализации в реальном масштабе времени, в частности, при
передаче данных по линиям связи.
Согласно данного метода система группового кодирования проверяет проходящий поток данных. Алгоритм остается пассивным
до тех пор, пока в этом потоке не обнаружатся три одинаковых смежных символа. После этого алгоритм начинает счет и
удаляет из потока данных до 250 одинаковых следующих друг за другом символов. Счетный байт посылается вслед за тремя
исходными символами, и передача продолжается. На рис. 8.2 показан пример группового кодирования потока данных.
Способность метода группового кодирования сжимать длинные последовательности очевидна. Тем не менее, рис. 8.2
иллюстрирует также одну из слабостей данного алгоритма. Кодирование группы из трех символов, наоборот, расширяет поток
данных.
На втором этапе сжатия данных протокол MNP5 использует адаптивное кодирование на основе метода Хаффмена, известное
также как
адаптивное частотное кодирование.
Этот способ кодирования основан на предположении,
Рис. 8.2.
Групповое кодирование по протоколу MNP5
что некоторые символы будут встречаться в потоке данных чаще, чем другие. Символы, которые встречаются чаще,
кодируются с использованием небольшого числа битов. Реже встречающиеся символы передаются с использованием более
длинных кодовых последовательностей.
Когда формат передаваемых данных относительно хорошо известен и постоянен, кодовые битовые последовательности, или
лексемы, могут быть определены заранее. Однако адаптивный алгоритм может подстраиваться под поток данных путем
"обучения" с последующим изменением своих лексем.
В протоколе MNP5 определяются 256 лексем для всех возможных 8-разрядных величин (октетов). Лексема состоит из
3-разрядного префикса (заголовка) и суффикса (тела, или основы), который может включать от 1 до 8 разрядов. Как передатчик,
так и приемник инициализируют свои символьно-лексемные таблицы в соответствии с табл. 8.9. Первая и последняя записи
Таблица 8.9. Карта символьно-лексемного кодирования в начале процедуры уплотнения данных
Значение октета (десятичное)
Заголовок лексемы
Тело лексемы
0
000
о
1
000
1
2
001
о
3
001
1
4
010
00
5
010
01
6
010
10
7
010
11
8
011
00
15
011
111
16
100
0000
..'.
31
100
1111
32
101
00000
.
63
101
11111
64
110
000000
127
110
111111
128
111
0000000
254
111
1111110
255
111
11111110
(строки) этой таблицы содержат наиболее и наименее часто встречающиеся октеты, соответственно.
После того как обработан каждый октет, таблица переопределяется, исходя из частоты появления каждого символа. Октетам,
которые появляются чаще всего, приписываются наиболее короткие лексемы. На приемном конце лексемы преобразуются в
символы. В соответствии с частотой появления тех или иных символов трансформируется таблица приемника. Тем самым
осуществляется самосинхронизация, таблиц кодирования и декодирования.


Формат кадров V.42
В стандарте V.42 используется понятие кадра данных. Согласно V.42 кадр должен передаваться только в синхронном режиме и
соответствовать рекомендациям протокола Х.25 или HDLC. Это означает, что в нем обязательно должны присутствовать поля
адреса и управления. Кадр LAPM выглядит следующим образом:
1 FLAG
1 ADRES
I CONTR
¦ INFORM ¦
FCS
FLAG
Здесь ADRES — поле адреса, которое позволяет по одному физическому каналу организовать несколько логических
(виртуальных) каналов. Формат поля адреса следующий:
DLCI ¦
с/г 1
0
где DLCI
(Data Link Connection Identifier) —
идентификатор соединения по звену данных, или адрес. Разряд с/г определяет,
содержит ли кадр команду или ответ на нее.
Для определения адреса допускается использовать один или два байта. В последнем случае последний разряд поля адреса
должен быть равен единице. Протокол V.42 определяет следующие допустимые значения идентификатора соединения DLCI:
> 0 — данные пользователя;
^ 1—31 —зарезервировано;
> 32—62 — не используется и не зарезервировано;
> 63 — служебные данные блока управления.
Заметим, что в протоколах MNP поле адреса не используется.
INFORM — поле информации пользователя, которое является необязательным, однако может присутствовать и в служебных
кадрах. Поле информации V.42 соответствует блоку PDU протоколов MNP.
CONTR — поле управления является обязательным для HDLC-подобных процедур, но в протоколах MNP не используется. Это
поле может состоять из одного или двух байт. Определить его размер можно по типу кадра, который определяется одним или
двумя последними битами первого байта. Последний нулевой бит означает двухбайтное поле управления формата I.
Комбинация 01 в последних битах соответствует типу кадра формата S. Комбинация 11 соответствует одному байту управления
кадра формата U. Остановимся подробнее на указанных типах кадров.
Кадры формата I (информационные) предназначены для передачи прикладных данных. В поле управления таких кадров
содержится порядковый номер
N(S)
передаваемого и номер
N(R)
подтверждаемого кадров (в протоколах MNP для таких целей
используется шесть байт), а также признак запроса ответа (бит Р). Параметры N(S) и N(R) LAPM аналогичны соответствующим
параметрам SSN и RSN протоколов MNP. Таким образом, поле управления кадра формата I выглядит следующим образом:
N{S)
0
N(R)
Р
Если передается команда или запрос, на который необходим ответ, бит Р должен быть равен единице. При Р равном нулю ответ
не требуется. В ответах на запрос этот бит также устанавливается равным единице.
При передаче последнего кадра пакета разряд Р устанавливается в " 1 ". Это означает окончанием передачи пакета. При
получении такого кадра приемная сторона должна передать подтверждение приема пакета данных.
Кадры формата S (супервизорные) используются для подтверждения получения информационных кадров, запроса их повторной
передачи или запроса временной задержки передачи кадров. Процедура LAPM допускает подтверждение правильного приема
данных любым кадром. При дуплексной передаче информации предпочтительно пересылать подтверждения принятых кадров
вместе с передаваемыми данными. В симплексном режиме передачи используются специальные супервизорные кадры.
Информация пользователя в этих кадрах не передается. Формат поля управления супервизорного кадра выглядит следующим
образом:
х
х ¦ х ¦ х ¦ S ¦ S I 0
1
N(R)
Р
где значение разрядов (S,S) определяет конкретное назначение супервизорного кадра; разряды
"хххх"
не используются.
Последний тип кадров формата U
(Unnumbered) —
ненумерованный:
I М
¦ M
M
p
M
M
1 I
1
где М — изменяемые функциональные биты, определяющие код и параметры кадра; последние два бита со значением (1,1)
являются признаком ненумерованного кадра. Кадры этого типа используются для обмена служебной информацией. В них не
допускается передача информации о подтверждении блоков.
С помощью поля управления CONTR однозначно определяется тип кадра и его формат. Как и для протоколов MNP, каждый
кадр можно рассматривать как определенную команду процедуры передачи данных. Приведем перечень кодов команд и
сообщений процедуры LAPM:
RR — готовность к приему (тип S):
о о
о о
о о
о
1
N(R)
р
RNR — неготовность к приему (тип S):
0 ¦ 0 ¦ 0 ¦ 0 ¦ 0 ¦ 1 ¦ 0
1
N(R)
Р
REJ — неприем кадра (тип S):
0 ¦ 0
0
о
1
о ¦ о
1
N(R)
р
SREJ — селективный неприем отдельного кадра (тип S):
о ¦ о ¦ о
0111110
1
N(R)
Р
SABME — установить асинхронный сбалансированный режим (тип U):
0
1
1
Р
1
1
1
1
DM — режим "Завершение связи" (тип U):
I о
о
о
р I
1 1
1
1
1
UI — ненумерованная информация (тип U):
0
о
о I
р
о
о
1 I
1 I
DISC — завершение связи (тип U):
I о
1
о
р
о
о
1
1 I
UA — ненумерованное подтверждение (тип U):
I 0
1
Р
1
1
1
1 I
FRMR — неприем кадра (тип U):
¦ 1
0
I 0
р
о
1
1
1 I
XID — идентификация обмена (тип U):
1 1
I 0
¦ 1
I 0 ¦
I 1 I
1
I 1
I 1 I
TEST — испытание (тип U):
I 1
1
1
0
о
о
1
I 1 I
Стандарт V.42 описывает функционирование модема с коррекцией ошибок как совокупность алгоритмов работы блока
управления и процедур блока защиты от ошибок. Алгоритмы блока управления регламентирует последовательность выполнения
различных процедур и команд.


Составление протоколов
В сетях с коммутацией пакетов различаются следующие три типа протоколов:
• протоколы связи между сетью общего пользования и терминалами пользователей;
• протоколы связи между устройствами коммутации внутри сети (общего пользования);
• протоколы между сетями с коммутацией пакетов (общего пользования).
Протоколы первого типа подразделяются на протоколы пакетных терминалов (т. е. терминалов, которые сами могут
производить сборку-разборку пакетов) и протоколы простых (непакетных) терминалов (т. е. терминалов, которые сами не
обеспечивают формирование пакетов, предоставляя эту операцию сети) (рис. 2.15).
Протоколы пакетных терминалов.
Структура формата пакета показана на рис. 2.16. Пакет содержит поле второго уровня для
устранения ошибок в тракте передачи, поле третьего уровня для обработки, связанной с коммутацией пакетов, и
информационное поле для пересылки данных между пользователями. В соответствии с рекомендациями Х.25 CCITT
рассмотрим протоколы пакетных терминалов и наиболее универсальные процедуры передачи данных по виртуальному каналу,
использующие поле третьего уровня.
В системах передачи по виртуальному каналу имеются два вида обслуживания: установление виртуального вызова VC и
организация постоянной виртуальной цепи PVC. В табл. 2.5 представлена классификация пакетов, используемых при
установлении виртуального вызова. Как следует из таблицы, все пакеты можно разделить на пять групп. Из них только пакет
установления и освобождения вызова является специфичным для VC, остальные используются и для VC, и для PVC. Пакет
сброса—это пакет начальной установки параметров, управляющих виртуальным каналом. В основном пакет сброса
используется при обслуживании PVC, при котором вызов не формируется. Так как пакет прерываний не влияет на управление
потоком, терминал может послать этот пакет в любое время после вызова. Поэтому в том случае, когда с терминала, в
частности, поступило требование задержать передачу, пакет прерываний может использоваться для наведения справок о
причине
Таблица 2. 6 Классификация и функциональное назначение пакетов
Тип пакета
Функциональное назначение пакета
Классифика
ционная
группа пакетов
DCE->DTE
DTE->DCE
функции пакета
наличие/отсутствие
поля DATA
Пакеты упра
Информационный па
Информационный па
Пересылка данных
Имеется (2оо байт)
вления пото
кет DT
кет DT
между пользовате
ком
лями
Пакет К ПРИЕМУ
Пакет К ПРИЕМУ ГО
Подтверждение дан
ГОТОВ RR
ТОВ RR
ных и сообщение о
возможности приема
Пакет К ПРИЕМУ НЕ
Пакет К ПРИЕМУ НЕ
Подтверждение дан
Отсутствует
ГОТОВ RNR
ГОТОВ RNR
ных и сообщение о
невозможности прие
ма
Пакеты устано
Пакет ВЫЗОВ ПРИ
Пакет ЗАПРОСИТЬ
Запрос вызова или
вления и ос
НЯТ CN
ВЫЗОВ CR
сообщение о приеме
вобождения
вызова
вызова
Пакет СОЕДИНЕНИЕ
Пакет ВЫЗОВ ПРИ
Сообщение о приеме
УСТАНОВЛЕНО СС
НЯТ СА
вызова (ответ) или
сообщение об
установке соединения
Имеется (128 байт) или
отсутствует
Пакет РАЗЪЕДИНИТЬ
Пакет ЗАПРОСИТЬ
Запрос на освобожде
СОЕДИНЕНИЕ CI
ВОССТАНОВЛЕНИЕ
CQ
ние вызова
Пакет ПОДТВЕРДИТЬ
ВОССТАНОВЛЕНИЕ
CF
Пакет ПОДТВЕРДИТЬ
РАЗЪЕДИНЕНИЕ CF
Подтверждение
освобождения вызова
Пакеты сброса
Пакет ВОЗВРАТИТЬ В
ИСХОДНОЕ
СОСТОЯНИЕ RI
Пакет ЗАПРОСИТЬ
СБРОС RQ
Запрос установки
порядкового номера
начала передачи
Отсутствует
Пакет ПОДТВЕРДИТЬ
СБРОС RF
Пакет ПОДТВЕРДИТЬ
СБРОС RF
Подтверждение
установки
порядкового номера
начала пере
дачи
Пакеты прерывания
Пакет ПРЕРВАТЬ
ПЕРЕДАЧУ IT
Пакет ПРЕРВАТЬ
ПЕРЕДАЧУ IT
Требование прервать
передачу (если при-
11 а т п я l^ p т
К
П Р
\Л
F -rlH 1 lldivt-l I\ ill
tii-i
Имеется (1 байт)
МУ НЕ ГОТОВ
(RNR))
Пакет ПОДТВЕРДИТЬ
ПРЕРЫВАНИЕ IF
Пакет ПОДТВЕРДИТЬ
ПРЕРЫВАНИЕ IF
Подтверждение
требования прервать
пе
Отсутствует
редачу
Пакеты рестарта
Пакет РЕСТАРТ
ВЫПОЛНЕН SI
Пакет ПРОИЗВЕСТИ
РЕСТАРТ SQ
Запрос на
аннулирование всех
вызовов
Отсутствует
Пакет ПОДТВЕРДИТЬ
РЕСТАРТ SF
Пакет ПОДТВЕРДИТЬ
РЕСТАРТ SF
Подтверждение
аннулирования всех
вызовов
Рис. 2.15. Взаимосвязь протоколов пакетных терминалов и протоколов сети
с коммутацией пакетов.
Протоколы коммутации пакетов (условия передачи) обычно включают протоколы трех типов. (X...)—номер спецификаций
стандарта CCITT SG VIII; PS — функция коммутации пакета: PAD — функция пакетирования: РТ — пакетный терминал; NPT —
простой
1
ермннал
Рис. 2.16. Формат пакета.
а —
пакет обязательно включает поле адреса места назначения и информационное ноле; б—подсоединение ноля
идентификатора типа пакета для включения управляющей (например. ;!ля извещения об окончании рассылки) н прочей
информации;
в —
присоединение поля идентификатора для мультиплексной передачи;
г—
добавление поля контрольной
синхронизации для обнаружения ошибок и их устранения. В соответствии с иерархической структурой модели ISO протоколы
коммутации пакетов включают протоколы уровня I. обеспечивающие электрический и физический тип связи между терминалом
и аппаратурой передач;! данных, и прпто|.п;|ы уровня 2. обеспе-чии'ло[цпо обработку, связанную с коммутацией иакетпп
такой задержки. Пакет рестарта используется после отладки системы при необходимости одновременном установки всех
логических каналов в исходное состояние. На рис. 2.17 показан пример последовательности передачи пакетов при стандартной
установке виртуального вызова между пакетными терминалами.
Так как в системах с коммутацией пакетов в отличие от систем с коммутацией каналов физически каналы между терминалами
не устанавливаются, то данные в основном можно передавать в момент организации вызова. Такую передачу называют
быстрой выборкой.
На рис. 2.18 показан пример последовательности такой передачи. Цель быстрой выборки состоит в
эффективной обработке вызовов коротких телеграмм (рис. 2.18). При установке виртуального вызова, как показано на рисунке,
для передачи двух пакетов требуется передача шести пакетов, тогда как при использовании быстрой выборки такую передачу
можно реализовать тремя пакетами. Возможности обработки с коммутацией пакетов существенно зависят от числа
пересылаемых пакетов, поэтому сокращение этого числа (по отношению к объему данных) может повысить эксплуатационные
характеристики всей сети в целом, и эффект быстрой выборки окажется значительным. Кроме того, пересылка информации для
установки (в частности, в момент вызова) устройств пользователя в исходное состояние позволяет дополнительно повысить
эффективность передачи (например, в системе VC + FS, рис. 2.14).
Рассмотрим особенности управления передачей данных с использованием окна.
Окном
называют максимальное число
пакетов, которые передающая сторона может посылать приемной без подтверждения приема. При таком управлении передачей
каждому пакету присваивается порядковый номер, и передающая сторона может пересылать пакеты с номерами в пределах
выбранного окна. Номер пакета обычно записывается по модулю 8 или по модулю 128. На рис. 2.19 представлена схема
управления потоком пакетов с использованием окна. Параметрами окна являются: порядковый номер WL начала передачи,
ширина окна (это размер окна W, т. е. максимальное число пакетов, которые можно передавать за один цикл) и порядковый
номер PS пакета окончания передачи. Порядковый номер WL корректируется порядковым номером PR приема, с которым
посылается пакет с извещением о подтверждении приема (пакеты К ПРИЕМУ ГОТОВ, либо К ПРИЕМУ НЕ ГОТОВ, указанные в
таблице 2.5). Следовательно, число Х оставшихся пакетов, которые пересылаются передающей стороной, определяется
следующим соотношением: Х = PR + W — PS.
Конкретный пример управления потоком с использованием окна показан на рис. 2.20. В системах, применяющих метод
-+
Рис. 2.18. Быстрая выборка данных.
а—обычный виртуальный вызов; б—быстрая выборка. Такая выборка позволяет сократить затраты на передачу пакетов за счет
уменьшения числа пересылаемых пакетов и может повысить эффективность передачи за счет пересылки управляющей
информации между терминалами пользователей в момент установления вызова,
скользящего окна, ширина последнего устанавливается в самом начале передачи и остается неизменной в процессе всей
передачи. Следовательно, к началу передачи необходимо иметь предварительные сведения о предполагаемых потоках данных
Рис. 2.19. Управление окном (для счетчиков по модулю 16).
Так как W = 7, PR •= 2, PS = 6, то число оставшихся пакетов, пересылаемых передающей стороной, оказывается равным Х "”
3.
и определить оптимальную для таких потоков ширину окна. Ниже приводится пример расчета ширины окна.
Для реализации непрерывной передачи ширина окна должна превышать величину Wmm, задаваемую (рис. 2.21) соотношением
вида
где
Тп—
время задержки передачи в сети;
Р\—
средняя длина пакета; Ss, бит/с—быстродействие абонентского канала на
передающей стороне; Sr, бит/с—быстродействие абонентского канала на приемной стороне; Тг, с—время подтверждения
приемным терминалом.
С одной стороны, приемная сторона должна иметь буфер, емкость которого соответствует ширине окна. С самого начала
передачи ширина приемного окна устанавливается того же размера, что и передающего, причем ширина последнего считается
основной. Следовательно, если ширина окна превышает необходимую величину, то емкость буфера на приемной стороне
возрастает. С другой стороны, передающая сторона должна иметь буфер для хранения тех пакетов, передача которых
завершена, а подтверждение об их приеме не получено. В этом случае при чрезмерно большой ширине окна приемная сторона
может замедлить с ответом. В результате может возрасти длительность резервирования буфера на передающей стороне за
один цикл, что потребует увеличения его емкости. Таким образом, с увеличением ширины окна повышается эффективность
передачи
ъдщх\
модулю 128. РТ — пакетный терминал; DCE — оконечное оборудование цепей передачи
о доставке r DCE пакетов до порядкового номера PS =1: 4 — пересылка пакета 1;
пересылка пакетов: 7 — пакет DT с запросом о возможности передачи; 8 -- пакет DT 10 — окно; 11 — прием фрагментов пакета;
12 — подтверждение о приеме пакетным тверждение о приеме пакетным терминалом пакетов до порядкового номера PS = 4;
с и ^вощением об ожидании отпета; 18 — пакет ОТ с извещением об окончании ответа.
Рис. 2.21. Определение минимального размера окна.
При непрерывной посылке пакетов необходимо учитывать задержку сигнала на время его прохождения в прямом и обратном
направлениях (время от момента посылки информационного пакета в сеть до получения ответа о приеме).
данных, но одновременно возрастает емкость буфера. Следовательно, для обеспечения требуемой производительности сети
необходимо найти приемлемое соотношение между эффективностью передачи и затратами на буфер.
На рис. 2.22 приведены форматы пакетов в соответствии с рекомендациями Х.25. Первый и второй байты, а также первый бит
третьего байта являются общими для формата всех пакетов одного типа. Идентификатор общего формата указывает тип пакета.
Номер группы логического канала и номер логического канала используются для идентификации источника и получателя пакета.
Третий байт указывает тип пакета. Для пакетов с данными, а также для пакетов К ПРИЕМУ ГОТОВ и К ПРИЕМУ НЕ ГОТОВ
указываются идентификатор типа пакета и порядковый номер приема.
В пакетах установки вызова имеется поле средств, где указываются некоторые необязательные свойства, которыми по
Рис. 2.22. Форматы пакетов.
а —
формат пакета с запросом о доставке посланного вызова либо пакета с подтверждением о приеме; б — формат
информационного пакета (счетчиков по модулю 8). P(R) — порядковый номер приема; М — бит продолжения данных; О—пакет
содержит данные; P(S) — порядковый номер передачи.
требованию вызывающего терминала должен обладать вызов. В пакетах с данными рекомендуются следующие размеры
информационных полей: 32, 64, 128, 256, 1024, 2048 и 4096 байт.
Выше были рассмотрены протоколы пакетных терминалов, которые в соответствии с рекомендацией Х.25 CCITT представляют
собой допустимое подмножество протоколов физического звена связи HDLC, предназначенного для передачи данных и
коммутации пакетов. Кроме процедур, содержащихся в рассмот-
репных протоколах, имеются процедуры доступа к каналам связи с целью устранения ошибок в тракте передачи (идентичные
процедурам управления каналов передачи данных HDLC, рекомендованным Международной организацией по стандартизации
ISO), а также процедуры установления связи между DCE и DTE.
Протоколы связи между устройствами коммутации внутри сети.
Устройство коммутации пакетов принимает пакеты с
передающего терминала и пересылает их на аналогичное устройство, непосредственно соединенное с приемным терминалом.
Сеть с коммутацией пакетов включает передающее и приемное устройства коммутации, связанные с передающим или
приемным терминалом соответственно, а также одно или несколько промежуточных устройств коммутации, осуществляющих
транзитную передачу пакетов между передающим и приемным устройствами. Поэтому для передачи пакетов между
устройствами используются как протоколы передачи, так и протоколы обмена информацией между передающей и приемной
станциями. При транзитной передаче пакета по существу достаточно знать лишь адрес терминала, которому предназначен
пакет. При организации связи между передающим и приемным устройствами коммутации должна быть известна информация
для начисления и получения оплаты за услуги, предоставляемые сетью, а также дополнительная служебная информация,
запрашиваемая терминалом. Часть необходимой служебной информации содержится в пакетах:
• для управления перегрузками, существенно затрудняющими передачу пакетов;
• для организации технического обслуживания сети;
- • -для проверки начальной загрузки IPL при удаленном вводе программ в устройства коммутации и в ряде других.
Протоколы связи между сетями с коммутацией пакетов.
Основные функции этих протоколов совпадают с функциями
вышеупомянутых протоколов связи между устройствами коммутации. Так как каждая сеть имеет своего администратора,
протоколы связи между сетями должны четко организовать взаимодействие администраторов с учетом ответственности
каждого из них. В качестве таких протоколов Комитет CCITT предлагает стандартную подсистему обмена информацией между
сетями общего пользования с коммутацией пакетов (рекомендации Х.25).


Протокол LLC уровня управления логическим каналом
В основу протокола LLC положен протокол HDLC (High-level Data Link Control Procedure), широко использующийся в
территориальных сетях.


Метод доступа к среде CSMA/CD
Подуровни LLC и MAC в стандарте Fast Ethernet не претерпели изменений. Напомним кратко их функции.


Ограничения длин сегментов DTE-DTE
В качестве
DTE (Data Terminal Equipment)
может выступать любой источник кадров данных для сети: сетевой адаптер, порт
моста, порт маршрутизатора, модуль управления сетью и другие подобные устройства. Порт повторителя не является DTE. В
типичной конфигурации сети Fast Ethernet несколько DTE подключается к портам повторителя, образуя сеть звездообразной
топологии.
Спецификация IEEE 802.3u определяет следующие максимальные значения сегментов DTE-DTE:
Стандарт
Тип кабеля
Максимальная длина сегмента
100Base-TX
Category 5 UTP
100 метров
100Base-FX
многомодовое оптоволокно
62.5/125 мкм
412 метров (полудуплекс)
2 км (полный дуплекс)
100Base-T4
Category 3,4 или 5 UTP
100 метров


Типы узлов и правила их соединения в сеть
Все станции в сети FDDI делятся на несколько типов по следующим признакам:
·
конечные станции или концентраторы;
·
по варианту присоединения к первичному и вторичному кольцам;
·
по количеству MAC-узлов и, соответственно, MAC-адресов у одной станции.


1. Введение
1.1. Принципы взаимодействия сетевых устройств
1.1.1. Интерфейсы, протоколы, стеки протоколов
1.1.2. Модель ISO/OSI
1.1.3. Функции уровней модели ISO/OSI
1.1.4. Протоколы взаимодействия приложений и протоколы транспортной подсистемы
1.1.5. Особенности протоколов, используемых в локальных и глобальных сетях
1.1.6. Источники стандартов
1.2. Характеристика популярных стеков коммуникационных протоколов
1.2.1. Стек OSI
1.2.2. Стек TCP/IP
1.2.3. Стек IPX/SPX
1.2.4. Стек NetBIOS/SMB
1.3.Функциональное назначение основных видов коммуникационного оборудования
1.3.1. Типовой состав оборудования локальной сети
1.3.2. Роль кабельной системы
1.3.3. Сетевые адаптеры
1.3.4. Физическая структуризация локальной сети. Повторители и концентраторы
1.3.5. Логическая структуризация сети. Мосты и коммутаторы
1.3.6. Маршрутизаторы
1.3.7. Модульные многофункциональные концентраторы
1.3.8. Функциональное соответствие видов коммуникационного оборудования уровням одели OSI
1.4. Оборудование для доступа к территориальным сетям
1.4.1. Магистральные средства и средства удаленного доступа
1.4.2. Типы территориальных сетей
1.4.3. Типы устройств доступа к территориальным сетям
1.4.4. Серверы удаленного доступа, удаленного управления и терминальные серверы
2. Физический уровень
2.1. Каналы передачи данных
2.1.1. Кабельные каналы связи
2.1.2. Оптоволоконные каналы
2.1.3. Беспроводные (радио) каналы и сети
2.2. Преобразование, кодировка и передача информации
2.2.1. Передача сигналов по линиям связи
2.2.1.1. Влияние шумов и помех
2.2.2. Протоколы модуляции
2.2.2.1. Основные сведения
2.2.2.2. Способы модуляции
2.2.2.2.1. Частотная модуляция
2.2.2.2.2. Относительная фазовая модуляция
2.2.2.2.3. Квадратурная амплитудная модуляция
2.2.2.3. Сигнально – кодовые конструкции (треллис-модуляция)
2.2.2.4. Основные протоколы модуляции
2.2.2.4.1. Протоколы V.21, Bell 103J
2.2.2.4.2. Протоколы V.22, V.22bis
2.2.2.4.3. Протокол V.23
2.2.2.4.4. Протоколы V.26, V.26bis, V.26ter
2.2.2.4.5. Протокол V.32
2.2.2.4.6. Протокол V.32bis
2.2.2.4.7. Протокол V.33
2.2.2.4.8. Протоколы V.34, V.34+, V.Fast
2.2.2.5. Скорость модуляции и передачи
2.2.2.6. Особенности модуляции
2.2.2.7. Особенности дуплексной передачи
2.2.2.8. Возможности адаптации
2.2.2.9. Вхождение в связь
2.2.2.10. Преимущества V34
2.2.2.11. Факс-протоколы модуляции
2.2.2.11.1. Протоколы V.27, V.27bis, V.27ter
2.2.2.11.2. Протокол V.29
2.2.2.11.3. Протокол V.17
2.2.2.12. Фирменные протоколы модуляции
2.2.2.12.1. Протокол V.32terbo
2.2.2.12.2. Протоколы ZyX, ZyCELL
2.2.2.12.3. Протоколы HST, RHST
2.2.2.12.4. Протоколы PEP, TurboPEP
2.2.3. Представление электрических сигналов в цифровой форме
2.2.4. Цифровые каналы T1 и Е1
2.2.5. Методы преобразования и передачи звуковых сигналов
2.2.5.1. Дельта-модуляция
2.2.5.2. Кодировщики голоса (Vocoder)
2.2.5.3. Передача голоса по каналам Интернет
2.2.6. Методы преобразования и передачи изображения
2.2.6.1. Стандарт MPEG-4
2.2.6.2. Стандарт MPEG-7
2.2.7. Методы сжатия информации
2.2.7.1. Алгоритм Зива-Лемпеля
2.2.7.2. Локально адаптивный алгоритм сжатия
2.2.7.3. Сжатие данных с использованием преобразования Барроуза-Вилера
2.2.7.4. Основные методы сжатия
2.2.7.5. Методы Шеннона-фано и Хаффмена
2.2.7.6. Алгоритм LZW
2.2.7.7. Сжатие данных в протоколах MNP
2.2.7.7.1. Протокол MNP5
2.2.7.7.2. Протокол MNP7
2.2.7.8. Сжатие данных по стандарту V.42bis
2.2.8. Обнаружение ошибок
2.2.9. Коррекция ошибок
2.2.9.1. Повышение достоверности передачи
2.2.9.1.1. Формат кадра протоколов с исправлением ошибок
2.2.9.1.2. Кодонезависимость протоколов с исправлением ошибок
2.2.9.1.3. Обнаружение ошибок
2.2.9.1.4. Методы повторной передачи (ARQ)
2.2.9.2. Протоколы MNP
2.2.9.2.1. Общие сведения
2.2.9.2.2. Форматы передаваемых данных
2.2.9.2.3. Процедура соединения MNP
2.2.9.2.4. Расширения MNP
2.2.9.3. Протокол V.42
2.2.9.3.1. Основные характеристики
2.2.9.3.2. Формат кадров V.42
2.2.9.3.3. Процедура соединения на основе V.42
2.2.9.3.4. Управление потоком в V.42
2.2.9.3.5. Вычисление контрольного поля кадра
2.3. Передача данных
2.3.1. Передача данных и архитектура сети
2.3.2. Каналы передачи данных
2.3.2.1. Каналы специальной связи
2.3.2.2. Каналы общего пользования
2.3.2.3. Коммутируемые сети передачи данных
2.3.3. Коммутируемые сети передачи данных
2.4. Коммутация каналов
2.4.1. Основные принципы и особенности коммутации каналов
2.4.1.1. Сокращение времени установки соединения
2.4.1.2. Улучшение качества передачи
2.4.1.3. Повышение скорости передачи
2.4.1.4. Более экономичная структура системы
2.4.2. Система вызова абонента
2.4.3. Распределение функций сети и терминалов
2.4.4. Технология уплотнения каналов
2.4.5. Методы построения телефонных каналов
2.4.6. Синхронизация сети
2.4.7. Перспективы развития
2.5. Коммутация пакетов
2.5.1. Общее представление о коммутации пакетов
2.5.1.1. Основные принципы коммутации пакетов
2.5.1.2. Особенности коммутации пакетов
2.5.1.3. Классификация систем с коммутацией пакетов
2.5.2. Основы теории коммутации пакетов
2.5.3. Основные функции, реализуемые при коммутации пакетов
2.5.3.1. Обработка вызовов
2.5.3.2. Составление протоколов
2.5.3.3. Сборка-разборка пакетов
2.5.3.4. Управление потоком (количеством пакетов) и управление перегрузками
2.5.3.5. Выбор маршрута (трассировка)
2.5.3.6. Последовательное упорядочение пакетов
2.5.4. Коммутация пакетов и микроэлектроника
2.5.4.1. Накладные расходы на обработку пакетов
2.5.4.2. Накладные расходы на каналы связи
2.5.4.3. Распределение функций
2.6. Структура физического уровня и его связь с MAC-подуровнем
2.6.1. Интерфейс MII
2.6.2. Передача данных через MII
2.6.3. Сообщения об ошибках в MII
2.6.4. Управление конфигурацией в MII
2.7. Физический уровень 100Base-FX - многомодовое оптоволокно
2.7.1. Метод кодирования 4B/5B
2.7.2. Передача 5-битовых кодов по линии методом NRZI
2.8. Физический уровень 100Base-TХ - двухпарная витая пара
2.8.1. Auto-negotiation - автопереговоры по принятию режима работы порта
2.8.2. Полнодуплексный режим работы
2.9. Физический уровень 100Base-T4 - четырехпарная витая пара
2.10. Физический подуровень PHY
2.10.1. Коды 4B/5B и их прием с помощью эластичного буфера
2.10.2. Процедура установления физического соединения
2.10.3. Конфигурирование внутреннего пути
3. Базовые технологии локальных сетей
3.1. Протоколы локальных сетей
3.2. Структура стандартов IEEE 802.1 - 802.5
3.3. Протокол LLC уровня управления логическим каналом
3.3.1. Три типа процедур уровня LLC
3.3.2. Структура кадров LLC
3.3.3. Заголовок SNAP
3.3.4. Временная диаграмма сервисов протокола LLC
3.4. Стандарты технологии Ethernet
3.4.1. Метод доступа CSMA/CD
3.4.2. Форматы кадров технологии Ethernet
3.4.3. Спецификации физической среды Ethernet
3.4.4. Стандарт 10Base-5
3.4.5. Стандарт 10Base-2
3.4.6. Стандарт 10Base-T
3.4.7. Стандарт 10Base-F
3.4.8. Правило 4-х повторителей
3.4.9. Методика расчета конфигурации сети Ethernet
3.5. Стандарт Token Bus (802.4)
3.6. Стандарт Token Ring (802.5)
3.6.1. Основные характеристики стандарта
3.6.2. Маркерный метод доступа к разделяемой среде
3.6.3. Форматы кадров Token Ring
3.6.4. Физическая реализация сетей Token Ring
3.7. Высокоскоростная технология Fast Ethernet (IEEE 802.3u)
3.7.1. Fast Ethernet как развитие классического Ethernet'а
3.7.1.1. Рост требований к пропускной способности локальных сетей
3.7.1.2. Способы повышения пропускной способности сети
3.7.1.3. Создание стандарта Fast Ethernet
3.7.2. Метод доступа к среде CSMA/CD
3.7.2.1. Подуровень Logical Link Control (LLC)
3.7.2.2. Подуровень управления доступом к среде Media Access Control (MAC)
3.7.3. Форматы кадров
3.7.4. Правила построения сегментов Fast Ethernet при использовании повторителей класса I и класса II
3.7.4.1. Ограничения длин сегментов DTE-DTE
3.7.4.2. Ограничения, связанные с соединениями с повторителями
3.7.5. Управление в сетях Fast Ethernet. Параметры протокола Ethernet, отслеживаемые агентами SNMP и RMON
3.7.6. В каких случаях рекомендуется использовать Fast Ethernet
3.7.6.1. Fast Ethernet в сетях рабочих групп
3.7.6.2. Fast Ethernet в магистралях зданий и кампусов
3.7.7. Обзор оборудования, поддерживающего Fast Ethernet
3.7.8. Пример построения сети по технологии Fast Ethernet
3.8. Протокол Gigabit Ethernet 85
3.9. Протоколы технологии FDDI 86
3.9.1. История создания стандарта FDDI
3.9.2. Основы технологии FDDI
3.9.2.1. Типы узлов и правила их соединения в сеть
3.9.2.2. Одиночное и двойное присоединение к сети
3.9.2.3. Количество MAC-узлов у станции
3.9.2.4. Типы портов станций и концентраторов FDDI и правила их соединения
3.9.2.5. Соединение Dual Homing
3.9.2.6. Присоединение станции к "блуждающему" MAC-узлу
3.9.2.7. Подключение станций с помощью оптических обходных переключателей (Optical Bypass Switch)
3.9.3.Спецификация зависящего от среды физического подуровня PMD
3.9.3.1. Структура физического соединения
3.9.3.2. Требования к мощности оптических сигналов
3.9.3.3. Кабели и разъемы
3.9.3.4. Функция определения сигнала уровня PMD
3.9.4. МАС-уровень
3.9.4.1. Функции МАС-уровня
3.9.4.2. Форматы кадра и токена
3.9.4.3. Операции МАС-уровня
3.9.4.4. Инициализация кольца
3.9.4.5. Управление доступом к кольцу
3.9.5. В каких случаях рекомендуется использовать технологию FDDI
3.9.6. Обзор оборудования, поддерживающего FDDI
3.9.7. Пример построения сети по технологии FDDI
3.10. Технология 100VG-AnyLAN
3.10.1. Общая характеристика технологии 100VG-AnyLAN
3.10.2. Стек протоколов технологии 100VG-AnyLAN
3.10.3. Функции уровня MAC
3.10.4. Функции уровня PMI
3.10.5. Функции уровня PMD
3.10.6. Пример работы сети 100VG-AnyLAN при передаче кадров данных
3.10.7. Обзор оборудования, поддерживающего технологию 100VG-AnyLAN
3.10.8. Пример корпоративной сети на технологии 100VG-AnyLAN
3.11. ArcNet
3.12. DQDB (802.6)
3.13. Радиосети (802.11)
4. Построение локальных сетей по стандартам физического и канального уровней
4.1. Структурированная кабельная система
4.1.1. Иерархия в кабельной системе
4.1.2. Выбор типа кабеля для горизонтальных подсистем
4.1.3. Выбор типа кабеля для вертикальных подсистем
4.1.4. Выбор типа кабеля для подсистем кампуса
4.2. Концентраторы и сетевые адаптеры
4.2.1. Сетевые адаптеры
4.2.1.1. Функции и характеристики сетевых адаптеров
4.2.1.2. Классификация сетевых адаптеров
4.2.2. Концентраторы
4.2.2.1. Основные и дополнительные функции концентраторов
4.2.2.2. Отключение портов
4.2.2.3. Поддержка резервных связей
4.2.2.4. Защита от несанкционированного доступа
4.2.2.5. Многосегментные концентраторы
4.2.2.6. Управление концентраторами по протоколу SNMP
4.2.2.7. Конструктивное исполнение концентраторов
4.3. Логическая структуризация сети с помощью мостов и коммутаторов
4.3.1. Причины логической структуризации локальных сетей
4.3.1.1. Ограничения сети построенной на общей разделяемой среде
4.3.1.2. Преимущества логической структуризации сети
4.3.1.3. Структуризация с помощью мостов и коммутаторов
4.3.2. Принципы работы мостов
4.3.2.1. Алгоритм работы прозрачного моста
4.3.2.2. Мосты с маршрутизацией от источника
4.3.2.3. Ограничения топологии сети, построенной на мостах
4.3.3. Коммутаторы локальных сетей
4.3.4. Полнодуплексные протоколы локальных сетей
4.3.4.1. Изменения в работе MAC – уровня при полнодуплексной работе
4.3.4.2. Проблема управления потоком данных при полнодуплексной работе
4.3.5. Управление потоком кадров при полнодуплексной работе
4.4. Техническая реализация и дополнительные функции коммутаторов
4.4.1. Особенности технической реализации коммутаторов
4.4.1.1. Коммутаторы на основе коммутационной матрицы
4.4.1.2. Коммутаторы с общей шиной
4.4.1.3. Коммутаторы с разделяемой памятью
4.4.1.4. Комбинированные коммутаторы
4.4.1.5. Конструктивное исполнение коммутаторов
4.4.2. Характеристики, влияющие на производительность коммутаторов
4.4.2.1. Скорость фильтрации и скорость продвижения
4.4.2.2. Коммутация «на лету» или с буферизацией
4.4.2.3. Размер адресной таблицы
4.4.2.4. Объем буфера кадров
4.4.3. Дополнительные функции коммутаторов
4.4.3.1. Поддержка алгоритма Spanning Tree
4.4.3.2. Трансляция протоколов канального уровня
4.4.3.3. Возможности коммутаторов по фильтрации трафика
4.4.3.4. Приоритетная обработка кадров
4.4.4. Виртуальные локальные сети
4.4.4.1. Назначение виртуальных сетей
4.4.4.2. Типы виртуальных сетей
4.4.4.3. VLAN на основе группировки портов
4.4.4.4. VLAN на основе группировки МАС-адресов
4.4.4.5. Использование меток в дополнительном поле кадра - стандарты 802.1 Q/p
4.4.4.6. Использование спецификации LANE
4.4.4.7. Использование сетевого протокола
4.4.5. Типовые схемы применения коммутаторов в локальных сетях
4.4.5.1. Сочетание коммутаторов и концентраторов
4.4.5.2. Стянутая в точку магистраль на коммутаторе
4.4.5.3. Распределенная магистраль на коммутаторах